Search found 619 matches

by Subsnowden
Thu Feb 07, 2019 12:55 pm
Forum: General Hammerin' and Wrenchin' (all model years)
Topic: Clutch rod plunger and associated removal
Replies: 47
Views: 1705

Re: Clutch rod plunger and associated removal

I grabbed one of the ears (which are on either side of the actuating lever) with some needle nose and rotated the plunger whilst pulling it out... wouldn’t come straight out but wiggling it a bit got it free... Been trying that over and over with vise grips, channel locks, needle nose, angled needl...
by Subsnowden
Wed Feb 06, 2019 4:14 pm
Forum: General Hammerin' and Wrenchin' (all model years)
Topic: Clutch rod plunger and associated removal
Replies: 47
Views: 1705

Re: Clutch rod plunger and associated removal

Take a deep breath and read some haiku. Talk to your dealer and see what he is willing to do to keep you as a happy customer. You maybe surprised, or maybe not, but it is as good a place to start as any. Stay calm and make it a moment of Zen. http://worldwideinterweb.com/wp-content/uploads/2017/04/...
by Subsnowden
Wed Feb 06, 2019 4:11 pm
Forum: General Hammerin' and Wrenchin' (all model years)
Topic: Clutch rod plunger and associated removal
Replies: 47
Views: 1705

Re: Clutch rod plunger and associated removal

It should just pull right out, Perhaps the o-ring has torn and jammed it up. Grip it carefully with some pliers and twist & pull on it and see if it comes out. :) Yup. Got the smashed knuckles and blood-blister pinched fingers to prove it. Vice grips, angled needle nose, good channel locks, penetra...
by Subsnowden
Wed Feb 06, 2019 2:55 pm
Forum: General Hammerin' and Wrenchin' (all model years)
Topic: Clutch rod plunger and associated removal
Replies: 47
Views: 1705

Clutch rod plunger and associated removal

The thing should just pull out right?! Of course my extended warranty went out 6 days ago and my clutch no-workie. Probably my thrust bearing but I don’t know because I can’t the $&#%@& plunger out. Do I HAVE to remove the tranny?! I’m about to set my Ural on fire...
by Subsnowden
Wed Feb 06, 2019 2:37 pm
Forum: 2014 & Later Model-Specific Wrenching Issues
Topic: 2016 Gear up sidecart tire is leaning in
Replies: 31
Views: 1307

Re: 2016 Gear up sidecart tire is leaning in

Sounds like one of your sidecar swingarm bushings has collapsed like mine. They “replaced” it under warranty and it’s still fubar’d. If Ural would make the swingarm forward mount bar about 1/4 inch or so longer it would probably stop it from happening.
by Subsnowden
Wed Feb 14, 2018 11:32 pm
Forum: 2014 & Later Model-Specific Wrenching Issues
Topic: Extra plug found
Replies: 23
Views: 1684

Re: Extra plug found

I have an extra plug in the birds nest behind the headlight...
by Subsnowden
Fri Feb 09, 2018 3:53 pm
Forum: 2014 & Later Model-Specific Wrenching Issues
Topic: Carry a spare fuel injector?
Replies: 23
Views: 1272

Re: Carry a spare fuel injector?

I am preparing for a year long trip through Central and Soith America. While I know that decent fuel is generally available, it’s certainly possible that we'll pick up some contaminated stuff. In addition to a pre-filter on the gas tank inlet, and spare fuel filters, I’m wondering if it makes sense...
by Subsnowden
Sat Jan 27, 2018 8:23 pm
Forum: Videos & Best of "How To" Posts
Topic: Finding neutral and shifting
Replies: 14
Views: 2182

Re: Finding neutral and shifting

My neutral light is on in 1st, N, and Reverse. I think my little tab is out of place...I’m about to set my Ural ablaze
by Subsnowden
Mon Jan 22, 2018 2:08 pm
Forum: 2014 & Later Model-Specific Wrenching Issues
Topic: Speedo and odometer inop
Replies: 11
Views: 840

Re: Speedo and odometer inop

it’s still running though. Sounds fine to me lol. Or maybe it’s Putin interfering
by Subsnowden
Fri Jan 19, 2018 2:33 pm
Forum: 2014 & Later Model-Specific Wrenching Issues
Topic: EFI TBs and ECU discussion
Replies: 68
Views: 3991

Re: EFI TBs and ECU discussion

Thank you Gobi!
by Subsnowden
Fri Jan 19, 2018 12:13 pm
Forum: 2014 & Later Model-Specific Wrenching Issues
Topic: Lost Power
Replies: 11
Views: 870

Re: Lost Power

Any updates?
by Subsnowden
Fri Jan 19, 2018 12:10 pm
Forum: 2014 & Later Model-Specific Wrenching Issues
Topic: I am getting frustrated...Battery light, cutting off of 2017 UPDATE 11/10/17!
Replies: 23
Views: 2652

Re: I am getting frustrated...Battery light, cutting off of 2017 UPDATE 11/10/17!

And the verdict is...a bad alternator. However that leads to another question. Now the bike is finicky when it is cold. Only on start up. as soon as it is a little bit warm it runs A-ok. But its fuel injected so I am not used to needing to warm it up before riding. However this is the first time it...
by Subsnowden
Fri Jan 19, 2018 12:06 pm
Forum: 2014 & Later Model-Specific Wrenching Issues
Topic: EFI TBs and ECU discussion
Replies: 68
Views: 3991

Re: EFI TBs and ECU discussion

Gobi, can you post a pic of that entire diagram?
by Subsnowden
Thu Jan 18, 2018 3:15 pm
Forum: 2014 & Later Model-Specific Wrenching Issues
Topic: EFI TBs and ECU discussion
Replies: 68
Views: 3991

Re: EFI TBs and ECU discussion

If anyone has a dealer tool near me I will probably do naughty things if you let me use it lol
by Subsnowden
Wed Jan 17, 2018 2:43 pm
Forum: 2014 & Later Model-Specific Wrenching Issues
Topic: Connected to ECU's and Balanced Throttle Bodies!!!!!!!
Replies: 514
Views: 60172

Re: RE: Re: Connected to ECU's and Balanced Throttle Bodies!!!!!!!

I'm late getting here so I didn't read the whole thread it's a mighty long one. What year is your Ural? I have a 2017 that constantly was shutting off and stalling at long red lights or long stop signs. I finally got sick and tired of it and because it was a 2017 I sent it back to the dealer with u...