Search found 39 matches

by MountainPeakCruiser
Sat Apr 11, 2020 5:57 pm
Forum: 2014 & Later Model-Specific Wrenching Issues
Topic: speedo issues
Replies: 10
Views: 456

Re: speedo issues

Taping around that very small section where the protective conduit was punctured fixed the problem completely. I guess I’ll be finding something heavier duty to protect that wire. It appears the conduit may have been punctured by the rubber donut on the output shaft.
by MountainPeakCruiser
Fri Apr 03, 2020 10:52 pm
Forum: 2014 & Later Model-Specific Wrenching Issues
Topic: speedo issues
Replies: 10
Views: 456

Re: speedo issues

I am also having speedometer issues. 2017 GearUp. It otherwise appears to be functioning normal until I start to accelerate past 20mph, the indicated speed begins to severely lag. It will be barely indicating 25mph when I’m above 40mph actual. It’s digital so it must rely on a sensor near the gearbo...
by MountainPeakCruiser
Sat Oct 12, 2019 4:47 pm
Forum: Ride Reports
Topic: Pike National Forest. Divide, CO
Replies: 6
Views: 437

Re: Pike National Forest. Divide, CO

Nice pics and video: I'll admit to having some pucker moments just watching the fun. :shock: Yeah, it’s hard to pinpoint every moment fun moment I wanted on the video. The GoPro app on my iPhone makes composing a video very easy but sometimes it’s hard to get it to do exactly what I want. The secti...
by MountainPeakCruiser
Sat Oct 12, 2019 4:43 pm
Forum: Ride Reports
Topic: Pike National Forest. Divide, CO
Replies: 6
Views: 437

Re: Pike National Forest. Divide, CO

We did the Rocky Mountain National Park last weekend. No dirt but 200 miles made it above 12,000'. If you're lucky enough to be away from traffic in Colorado, it will be a nice ride. https://youtu.be/e8tUMLVHnag https://goo.gl/maps/PAHPBWn9FZZwDHUg6 That’s a beautiful ride! I’ve done that on a coup...
by MountainPeakCruiser
Fri Sep 27, 2019 11:44 pm
Forum: 2014 & Later Model-Specific Wrenching Issues
Topic: Found yet another dealer mistake, wrong plugs and gap not set
Replies: 9
Views: 545

Re: Found yet another dealer mistake, wrong plugs and gap not set

Eric N wrote:
Wed Sep 25, 2019 11:04 pm

Randy with Unique in Loveland is very good, knows his stuff.
You’re not the first person that has recommended that shop.
by MountainPeakCruiser
Fri Sep 27, 2019 2:30 pm
Forum: Ride Reports
Topic: Pike National Forest. Divide, CO
Replies: 6
Views: 437

Pike National Forest. Divide, CO

Kaliram taking me for a beautiful ride through Pike National Forest north of Divide, CO.
https://youtu.be/gX2ps67LFP8
by MountainPeakCruiser
Wed Sep 25, 2019 10:28 pm
Forum: 2014 & Later Model-Specific Wrenching Issues
Topic: Found yet another dealer mistake, wrong plugs and gap not set
Replies: 9
Views: 545

Re: Found yet another dealer mistake, wrong plugs and gap not set

Your post jogged my memory, so I reviewed my maintenance spreadsheet. The spark plugs installed on my 2018 Gear Up, presumably at the factory in Russia, were NGK BP7HS. They were replaced at 6,xxx miles with two NGK BP R 7HS spark plugs, these being the precise designation illustrated in the Owner'...
by MountainPeakCruiser
Tue Sep 24, 2019 6:52 pm
Forum: 2014 & Later Model-Specific Wrenching Issues
Topic: Found yet another dealer mistake, wrong plugs and gap not set
Replies: 9
Views: 545

Re: Found yet another dealer mistake, wrong plugs and gap not set

Trumpetwasher wrote:
Tue Sep 24, 2019 6:47 pm
Two of the reasons I run E3.32 plugs. Factory gapped and covers both heat ranges.
I’m not familiar with E3 plugs.
by MountainPeakCruiser
Tue Sep 24, 2019 6:39 pm
Forum: 2014 & Later Model-Specific Wrenching Issues
Topic: Found yet another dealer mistake, wrong plugs and gap not set
Replies: 9
Views: 545

Found yet another dealer mistake, wrong plugs and gap not set

I bought my 2017 GearUp with very low miles (200mi) from from a local dealership. It had been purchased from that dealership and had been traded back to that dealer less than 2 years later; every bit of assembly and maintenance on this bike had been handled by this dealer before I bought it. So, I k...
by MountainPeakCruiser
Fri Sep 13, 2019 10:18 pm
Forum: 2014 & Later Model-Specific Wrenching Issues
Topic: Ran Out of Gas? Video for Bleeding Fuel Pump on EFI bikes
Replies: 4
Views: 311

Re: Ran Out of Gas? Video for Bleeding Fuel Pump on EFI bikes

All well and good but fer chissake don't break off the plastic outlet spout, then you're screwed, someone on this forum has done this. Knowing my luck I'll struggle to press the tabs down and break something. :( I've already broken off the clip that secures the cover (actually a plug with no pins i...
by MountainPeakCruiser
Thu Sep 12, 2019 9:57 pm
Forum: Modifications & Accessories
Topic: New GPR 2-into-1 right exit high mount stainless exhaust
Replies: 63
Views: 2383

Re: New GPR 2-into-1 right exit high mount stainless exhaust

I like the looks and sound of the GPR but I already have a Kalaber skid plate. I picked up an extra set of factory head pipes and I'm going to order some pre-bent exhaust tubing and weld up my own 2 into 1 exhaust . It won't be as pretty as the GPR but it will be considerably cheaper. I would say, ...
by MountainPeakCruiser
Wed Sep 11, 2019 11:40 pm
Forum: The Virtual Watering Hole
Topic: Ural: New Two Into 1 High rise Exhaust
Replies: 18
Views: 801

Re: Ural: New Two Into 1 High rise Exhaust

I have a thread on this exhaust in the Mods forum. I can’t say enough good things about the exhaust. It has a fit and finish that you can only expect from a performance exhaust company. I can attest to excess fumes, in a partially enclosed space it is noticeable that the cats have been removed; so I...